易语言首字母大写小写

小泽 2020-05-12 01:37 1条评论

image.png

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 小写, 整数型, , , 字符代码

.子程序 _按钮1_被单击, , , 存在即转换成大写
.局部变量 结果, 文本型

结果 = 字符 (到字节 (小写))
.如果真 (取文本左边 (编辑框1.内容, 1) = 结果)
    编辑框1.内容 = 文本替换 (编辑框1.内容, 1, 1, 到大写 (结果))
.如果真结束


.子程序 _编辑框1_字符输入, 整数型
.参数 字符代码, 整数型, , 小写为真,返回数值

.如果真 (字符代码 ≥ 97 且 字符代码 ≤ 122)  ' a-z
    .如果真 (取文本长度 (编辑框1.内容) = 0)  ' 不能等于1,如果是按键配合其它来做之类就是1
        小写 = 字符代码
    .如果真结束
    ' 只取文本开头
.如果真结束
' ps:只执行一次
' 大写字符:65-90
本文标签: 首字母大写, 首字母小写
相关文章
0.0

说点什么吧
  • 全部评论(0