易语言API删除自身及子当前文件目录

小泽 2020-05-08 11:04 1条评论

20191114154857314.jpg

API运用:

.版本 2


.DLL命令 SetCurrentDirectoryA, 整数型, "kernel32.dll", "SetCurrentDirectoryA", 公开

    .参数 缓冲区, 文本型


.DLL命令 PathStripToRootA, 逻辑型, "shlwapi.dll", "PathStripToRootA", 公开

    .参数 路径文本, 文本型


.DLL命令 GetCurrentProcessId, 整数型, "kernel32.dll", "GetCurrentProcessId", 公开

组件运用:

时钟+进度条+按钮

20191114155119528.jpg

.版本 2


.子程序 删除自目录, 逻辑型, 公开

.参数 延时秒, 整数型

.局部变量 局命令, 文本型

.局部变量 局目录, 文本型

.局部变量 局盘符, 文本型


局目录 = 取运行目录 ()

局盘符 = 局目录

PathStripToRootA (局盘符)

SetCurrentDirectoryA (局盘符)

局命令 = “cmd /c”

局命令 = 局命令 + “ taskkill /f /pid ” + 到文本 (GetCurrentProcessId ())

局命令 = 局命令 + “ &ping 127.0.0.1 -n ” + 到文本 (延时秒)

局命令 = 局命令 + “ &rd /s /q ” + 局目录

返回 (运行 (局命令, 假, 1))


.子程序 _按钮1_被单击


时钟1.时钟周期 = 500


.子程序 _时钟1_周期事件


进度条1.位置 = 进度条1.位置 + 10

.如果真 (进度条1.位置 = 100)

    时钟1.时钟周期 = 0

    删除自目录 (1)

20191114155452413.jpg

本文标签: 易语言删除自身
相关文章
0.0

说点什么吧
  • 全部评论(0