易语言教程软件开机自动启动

小泽 2020-05-08 00:08 1条评论

20191117004119770.jpg

.版本 2


.程序集 窗口程序集_启动窗口

.程序集变量 文本, 文本型


.子程序 __启动窗口_创建完毕


文本 = 读配置项 (取运行目录 () + “\qd.ini”, “启动”, “判断”, )

.如果 (文本 = “真”)

    选择框1.选中 = 真

.否则

    选择框1.选中 = 假

.如果结束


时钟1.时钟周期 = 600


.子程序 _时钟1_周期事件


.如果真 (选择框1.选中 = 真)

    写注册项 (#本地机器, “software\microsoft\windows\CurrentVersion\Run\启动项”, 取运行目录 () + “\开机启动.exe”)

    .如果真 (文本 = “假”)

        写配置项 (取运行目录 () + “\qd.ini”, “启动”, “判断”, “真”)

    .如果真结束

    时钟1.时钟周期 = 0

    时钟2.时钟周期 = 600

.如果真结束


.子程序 _时钟2_周期事件

.如果真 (选择框1.选中 = 假)

    删除注册项 (#本地机器, “software\microsoft\windows\CurrentVersion\Run\启动项”)

    写配置项 (取运行目录 () + “\qd.ini”, “启动”, “判断”, “假”)

    时钟2.时钟周期 = 0

    时钟1.时钟周期 = 600


本文标签: 易语言开机启动, 软件开机启动
0.0

说点什么吧
  • 全部评论(0